Important information regarding vzctl 3.0.30.1 (Released 2012-01-12)

The latest version of vzctl (3.0.30.1) now requires the swappages UBC parameter to be set in the containers config before it will start the container. The issue is that swappages is a new parameter and existing non VSwap containers won’t have this setting in there config file.

We are currently testing a fix for release shortly. If you need to downgrade your vzctl version you can do the following on any of your openvz host nodes:

cp /etc/vz/vz.conf /etc/vz/vz.conf.moved
yum remove vzctl vzctl-lib
cd /tmp
wget http://download.openvz.org/utils/vzctl/3.0.29.3/vzctl-3.0.29.3-1.x86_64.rpm
wget http://download.openvz.org/utils/vzctl/3.0.29.3/vzctl-lib-3.0.29.3-1.x86_64.rpm
rpm -ihv vzctl-3.0.29.3-1.x86_64.rpm vzctl-lib-3.0.29.3-1.x86_64.rpm
cp /etc/vz/vz.conf.moved /etc/vz/vz.conf
service vz restart

Please note the above instructions are for x86_64 (64bit) host nodes only.

Menu